Wideband stuck on 19.9

I installed a new Spartan Lite 3, and it worked wonderfully for two drives, now when turning it on it reads 16.5 for about 5 secs then goes to 19.9 and stays there. Nothing has changed since installation.
Any ideas?

Ok no help so far, but I was assuming a dirty sensor as when it worked for the first two days it was reading rich. I took the sensor out today and it was covered in black filth. So gave it a quick rinse in petrol, nothing more than a swish around and wipe with a soft cloth. There are holes in the tip of it that must get caked up I guess. RE-installed and now after initially jumping around in the high ‘teens’ it sits on 16.6.
So the plan is to now take it out and let it soak in petrol for a while and a blast of compressed air. We’ll see how it goes after that. P.S. I have leaned off the mixture a tad too.

Well an update for whomever cares, not 14point7 as only crickets from the manufacturer or distributor…
Soaking the sensor made no difference, other sites have reviews of sensors just dying, maybe the O2 sensor (Bosch) has packed it in, but they’re not cheap to replace to test… thanks for wasting my money, will have to try a complete different setup and put this experience down to…well experience I guess.


Can you send me an email or private message with your order number?

Hi. My order number was #10834

I’m having the same issue.

Same issue with spartan 2 wideband controller.