Spartan 3 will not load firmware

Recently purchased a Spartan 3 running with a MS3 on CANBUS and driving a gauge with the analog output. It is currently running FW 1.04 which it shipped with.
I am having the following issues:

  • Only responds to serial commands sometimes. sometimes it will not work at all, sometimes it will come back after a power cycle.
  • I cannot get the firmware to load. Following the instructions - after entering the com # and pressing enter the widow just disappears. I have tried FW 1.06, 1.07 & 1.08 all with the same results. The solid green LED is coming on.
  • O2 output seems to hang and lock up at certain times. On a free rev of the engine it seems to consistently lock up on a lean spike around the 14.x range and then when it comes back and goes richer it will lock up around the 15.x range. Its really strange that you can get it to repeatably do it. I’m running my old LC2 in parallel at the moment and can compare what that is doing at the same time. I read a thread on here that seemed similar (due to the sensor cooling) and have changed to PERF1 which seems to have solved that issue (just tried that tonight, so will see how that goes with further testing). Would really like to try the later firmware to see if it will be better on PERF0 though.
  • Sometimes the AFR just does not output at all on CAN or the analog. Maybe this is related to the previous point and the sensor is too cold? I was two minutes from home last night before it started working all of a sudden.

I have tried reloading fresh FTDI drivers, 2 separate computers, separate USB cables, different firmware versions with no luck. Using termite for serial commands.


Can you send me an email, You can send it back to me and I will do the firmware update for you.